1999 Fiat Brava 1.6 16v Power Loss

Car Mechanics Help!


Q   I have a 1999 Fiat Brava 1.6 16v auto. The car starts and idles fine, the throttle revs the engine while idling, but when you engage drive and try to move off, the car has no power. The engine won’t rev at all and the car will only move very slowly. I am at a complete loss as to what is causing this.
Jonathan Dean

A   I would first check the condition of the engine loom and connections. It could be that, when selecting gear, the slight movement in the engine is enough to cause a fracture in the loom or connecting plug to show up. I would also check the vacuum hoses, which could also be similarly affected.

Having checked the engine loom and connections, if no faults are found, I would suspect the problem to be due to the gearbox ECU. This should be situated under the rear passenger seat and I would start by checking that the connection plug is clean and dry. The gearbox diagnostic connector is also under the rear seat and it may be advisable to get someone with a suitable diagnostic scanner to check this for codes.

Another option would be to disconnect the battery for a while to allow the ECU to reset.

Car Mechanics Logo SmallHave A Problem Vehicle? Get In Touch…

Car Mechanics has the answer in the shape of technical editor Steve Rothwell. Email your questions to carmechanicshelp@yahoo.co.uk.

Car Parts and Accessories? We can Help!

Looking for a specific car part or accessory? Need help choosing the right part?
 Autosessive.com    0844 736 9933     sales@autosessive.com

Add a Comment

Your email address will not be published. Required fields are marked *